bundle install で nokogiri がインストールできない。

前はそんなことなかったんだけど、railsの環境を少し変えたらbundle install するときにnokorgiri でこけた。

実行環境

普通にbundle installとエラーが出る。

bundle を最初から設定していきます。

作成されたGemfileに必要なgemを追加して、bundle install するとnokogiriをインストールする際に失敗してしまいました。

上記のようなエラーが出ました。

解決策

ぶっちゃけ原因はよくわからないのですが、どうやらnokogiriをシステムのライブラリを使うようにするとうまくいくようです。

なので、bundleにまず設定します。

Linux側では書きが必要なのでインストールしておきましょう。

上記を行った後に再度bundle installしましょう

SNSでもご購読できます。

コメントを残す

*